summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-11-09 19:59:51 +0000
committerEfraim Flashner <efraim@flashner.co.il>2022-11-15 12:30:48 +0200
commit3775e997baeda2791694df2333b1ab9a804da204 (patch)
tree0b2dfaef124f9df927e51f943d2a31815be2b091
parent153e7d895656ad9027083614f945f65cc165c93e (diff)
gnu: python-mdurl: Enable tests.
* gnu/packages/python-xyz.scm (python-mdurl): Enable tests. [source]: Use git checkout with tests. [build-system]: Use pyproject-build-system. [native-inputs]: Add python-pytest. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/python-xyz.scm33
1 files changed, 11 insertions, 22 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 845cc4d4a5..1758450c2f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -783,28 +783,17 @@ that best match text queries.")
(package
(name "python-mdurl")
(version "0.1.2")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "mdurl" version))
- (sha256
- (base32
- "1fn1hy35h9grggwqax90zcb52inlfxrxsm27vlqqz8zfyllkshdv"))))
- (build-system python-build-system)
- (arguments
- (list
- #:tests? #f ;pypi source does not contain tests
- #:phases
- #~(modify-phases %standard-phases
- (replace 'build
- (lambda _ (invoke "flit" "build")))
- (replace 'install
- (lambda _
- (for-each
- (lambda (wheel)
- (invoke "python" "-m" "pip" "install"
- wheel (string-append "--prefix=" #$output)))
- (find-files "dist" "\\.whl$")))))))
- (native-inputs (list python-flit))
+ (source
+ (origin
+ (method git-fetch) ; no tests data in PyPi package
+ (uri (git-reference
+ (url "https://github.com/executablebooks/mdurl")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0csc777q42jzv4zgdzxmwp8xqlb92ws1jvj09m2smh4klw67q5f3"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-flit python-pytest))
(home-page "https://github.com/executablebooks/mdurl")
(synopsis "Markdown URL utilities")
(description