summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-28 15:46:16 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-28 16:27:37 +0100
commit37e35f6f59be0876efdd60f61cd3f3e9b0a2195a (patch)
tree925015f79a8ea2d96e98f7da740f1e6f1da37045
parent3220226b4043bf71678269a2e11f84b55c7c8556 (diff)
gnu: Add go-github-com-multiformats-go-multicodec.
* gnu/packages/golang-xyz.scm (go-github-com-multiformats-go-multicodec): New variable. Change-Id: I2adf3f8200818675ba1de6322a1280d4b231cda4
-rw-r--r--gnu/packages/golang-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 53832951f6..4e40e148f2 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2454,6 +2454,41 @@ command line flags, config files, and default struct values.")
multibase} (self identifying base encodings) in Go.")
(license license:expat)))
+(define-public go-github-com-multiformats-go-multicodec
+ (package
+ (name "go-github-com-multiformats-go-multicodec")
+ (version "0.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/multiformats/go-multicodec")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vyc85aa9k644l9m3safiz7kk8mm84jclridsp0qnxfj2kcqgipd"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.19
+ #:import-path "github.com/multiformats/go-multicodec"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'copy-multibase-specs
+ (lambda* (#:key import-path #:allow-other-keys)
+ (copy-recursively
+ (string-append #$(this-package-native-input
+ "specification-multicodec")
+ "/share/multicodec/")
+ (string-append "src/" import-path "/spec/multicodec/")))))))
+ (native-inputs
+ (list specification-multicodec))
+ (home-page "https://github.com/multiformats/go-multicodec")
+ (synopsis "Golang constants for the multicodec table")
+ (description
+ "Package multicodec exposes the multicodec table as Go constants.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public go-github-com-multiformats-go-varint
(package
(name "go-github-com-multiformats-go-varint")