summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundation.xyz>2024-04-11 13:00:45 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-04-28 09:53:34 -0400
commit37f76ab50a9709a0fb214de4731d8d75cf9430a3 (patch)
tree6a8567f6be5def87aa9863deca875eb3385736df
parent0b8675daf2bec868db64a7af11abfa49d1e58f8f (diff)
gnu: soqt: Update to 1.6.2.
* gnu/packages/qt.scm (soqt): Update to 1.6.2. Change-Id: Ie4c9f0c4cff7584801952cc561f4d6fa3515d0ec Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/qt.scm48
1 files changed, 23 insertions, 25 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 2b3307fbb5..13aadc8190 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -5081,33 +5081,31 @@ configurable also via HTTP.")
(license license:gpl3+)))
(define-public soqt
- (let ((commit-ref "fb8f655632bb9c9c60e0ff9fa69a5ba22d3ff99d")
- (revision "1"))
- (package
- (name "soqt")
- (version (git-version "1.6.0" revision commit-ref))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/coin3d/soqt")
- (commit commit-ref)
- (recursive? #t)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "16vikb3fy8rmk10sg5g0gy2c343hi3x7zccsga90ssnkzpq6m032"))))
- (build-system cmake-build-system)
- (arguments '(#:tests? #f)) ; There are no tests
- (native-inputs
- (list pkg-config cmake))
- (inputs
- (list qtbase-5 coin3d))
- (home-page "https://github.com/coin3d/soqt")
- (synopsis "Qt GUI component toolkit library for Coin")
- (description "SoQt is a Qt GUI component toolkit library for Coin. It is
+ (package
+ (name "soqt")
+ (version "1.6.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/coin3d/soqt")
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rsfc4wmghl9fr4bwh9rpzjwzsmx00k4ki5gyvy85nb4kbmr9dwv"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ; There are no tests
+ (native-inputs
+ (list pkg-config cmake))
+ (inputs
+ (list qtbase-5 coin3d))
+ (home-page "https://github.com/coin3d/soqt")
+ (synopsis "Qt GUI component toolkit library for Coin")
+ (description "SoQt is a Qt GUI component toolkit library for Coin. It is
also compatible with SGI and TGS Open Inventor, and the API is based on the API
of the InventorXt GUI component toolkit.")
- (license license:bsd-3))))
+ (license license:bsd-3)))
(define-public libdbusmenu-qt
(package