summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-12 14:07:38 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-12 15:39:18 -0400
commit397147aaad2e5d357479c0ff3ac3042432e320ae (patch)
tree7d876d85202497b86cf96ca4aef97ffd5e3d1322
parent3e0902cbcc6acf0079283f7f8e6afdbe66f81fc9 (diff)
gnu: autotrace: Update to 0.40.0-20200219.65.
* gnu/packages/graphics.scm (autotrace): Update to 0.40.0-20200219.65. [arguments]: Delete field. [native-inputs, inputs]: Use new style.
-rw-r--r--gnu/packages/graphics.scm41
1 files changed, 14 insertions, 27 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index c193be1efb..4fd16d7ce5 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -302,7 +302,7 @@ objects!")
(license license:lgpl2.1+)))
(define-public autotrace
- (let ((commit "travis-20190624.59")
+ (let ((commit "travis-20200219.65")
(version-base "0.40.0"))
(package
(name "autotrace")
@@ -319,35 +319,22 @@ objects!")
(patches (search-patches "autotrace-glib-compat.patch"))
(sha256
(base32
- "0mk4yavy42dj0pszr1ggnggpvmzs4ds46caa9wr55cqsypn7bq6s"))))
+ "1p9gy2vg0jzwjwz34lj95vvknnyswpc4qq63j83bh0m1gz09qh2w"))))
(build-system gnu-build-system)
- (arguments
- `(#:phases (modify-phases %standard-phases
- ;; See: https://github.com/autotrace/autotrace/issues/27.
- (add-after 'unpack 'include-spline.h-header
- (lambda _
- (substitute* "Makefile.am"
- ((".*src/types.h.*" all)
- (string-append all "\t\tsrc/spline.h \\\n")))
- #t))
- ;; See: https://github.com/autotrace/autotrace/issues/26.
- (replace 'check
- (lambda _
- (invoke "sh" "tests/runtests.sh"))))))
(native-inputs
- `(("which" ,which)
- ("pkg-config" ,pkg-config)
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("intltool" ,intltool)
- ("libtool" ,libtool)
- ("gettext" ,gettext-minimal)))
+ (list which
+ pkg-config
+ autoconf
+ automake
+ intltool
+ libtool
+ gettext-minimal))
(inputs
- `(("glib" ,glib)
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("imagemagick" ,imagemagick)
- ("pstoedit" ,pstoedit)))
+ (list glib
+ libjpeg-turbo
+ libpng
+ imagemagick
+ pstoedit))
(home-page "https://github.com/autotrace/autotrace")
(synopsis "Bitmap to vector graphics converter")
(description "AutoTrace is a utility for converting bitmap into vector