summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundation.xyz>2024-07-03 18:36:42 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-03 22:29:58 +0100
commit39a7b295b87d42787af8b8d1dd4ca7fb474d56bf (patch)
tree8c3dc34a5302de305a1933f27f13181e4c7a7c9b
parent2dd43fdacc1334f7ff3f42ac00d8dbf1f13cc79d (diff)
gnu: buildah: Fix build.
* gnu/packages/containers.scm (buildah)<arguments>: Remove 'remove-go-references phase, add 'patch-buildflags phase and remove imported modules. Change-Id: Id89ea5c90ba8064484eec460efdfa592c974adca Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/containers.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index 241858af94..650d79ac37 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -618,9 +618,6 @@ being rootless and not requiring any daemon to be running.")
#$go-github-com-go-md2man "/bin/go-md2man"))
#:tests? #f ; /sys/fs/cgroup not set up in guix sandbox
#:test-target "test-unit"
- #:imported-modules
- (source-module-closure `(,@%gnu-build-system-modules
- (guix build go-build-system)))
#:phases
#~(modify-phases %standard-phases
(delete 'configure)
@@ -632,6 +629,12 @@ being rootless and not requiring any daemon to be running.")
;; Make <4.4 causing CC not to be propagated into $(shell ...)
;; calls. Can be removed once we update to >4.3.
(setenv "CC" #$(cc-for-target))))
+ ;; Add -trimpath to build flags to avoid keeping references to go
+ ;; packages.
+ (add-after 'set-env 'patch-buildflags
+ (lambda _
+ (substitute* "Makefile"
+ (("BUILDFLAGS :=") "BUILDFLAGS := -trimpath "))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
@@ -659,8 +662,6 @@ being rootless and not requiring any daemon to be running.")
,(string-append #$gcc "/bin") ; cpp
,(string-append #$passt "/bin")
"/run/setuid-programs")))))
- (add-after 'install 'remove-go-references
- (@@ (guix build go-build-system) remove-go-references))
(add-after 'install 'install-completions
(lambda _
(invoke "make" "install.completions"