summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 16:44:58 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:28 -0600
commit3a8ee9d163651c02f48b324c20e63292b02c1cef (patch)
treeb487cf3ef01b93fecd6033629ee9297f1b01a548
parentbc4899e3d9eb4b975705029f997d1a73d84f845e (diff)
gnu: Add Exception-Class.
* gnu/packages/perl.scm (perl-exception-class): New variable.
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 1f1ce340e0..dd9d4836cb 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -581,6 +581,28 @@ environment, other than a fixed list of specified variables. Compilation
errors are rethrown automatically.")
(license (package-license perl))))
+(define-public perl-exception-class
+ (package
+ (name "perl-exception-class")
+ (version "1.39")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DR/DROLSKY/"
+ "Exception-Class-" version ".tar.gz"))
+ (sha256
+ (base32
+ "10r06v6568s33p6h9f9ml0iabc07id86mjkf74gy7ld6d5m7b741"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-devel-stacktrace" ,perl-devel-stacktrace)
+ ("perl-class-data-inheritable" ,perl-class-data-inheritable)))
+ (home-page "http://search.cpan.org/dist/Exception-Class")
+ (synopsis "Allows you to declare real exception classes in Perl")
+ (description "Exception::Class allows you to declare exception hierarchies
+in your modules in a \"Java-esque\" manner.")
+ (license (package-license perl))))
+
(define-public perl-exporter-lite
(package
(name "perl-exporter-lite")