summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-12 21:41:24 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-12 23:33:23 +0000
commit3da105865c53c80c2ed7ac6e54dfb320d1ef06d9 (patch)
tree3e99c145ee755ee81fb1513d21dcd32a1c232155
parentae60a953d61d6bd28adfa2f73fdbd37202039091 (diff)
gnu: go-github-com-rcrowley-go-metrics: Move to golang-xyz.
* gnu/packages/syncthing.scm (go-github-com-rcrowley-go-metrics): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Id153e4b8295c1430077941c5e4ee854ef28a56fa
-rw-r--r--gnu/packages/golang-xyz.scm33
-rw-r--r--gnu/packages/syncthing.scm30
2 files changed, 32 insertions, 31 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index bdf29d64b4..6a26cd1b06 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2018, 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017, 2018, 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
;;; Copyright © 2023 Thomas Ieong <th.ieong@free.fr>
@@ -353,6 +354,36 @@ updates the registry.")
(home-page "https://github.com/prometheus/client_model")
(license license:asl2.0))))
+(define-public go-github-com-rcrowley-go-metrics
+ (let ((commit "cac0b30c2563378d434b5af411844adff8e32960")
+ (revision "2"))
+ (package
+ (name "go-github-com-rcrowley-go-metrics")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rcrowley/go-metrics")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1hfxffnpaw49pr3wrkbzq3pnv3nyzsvk5dxndv0yz70xlrbg8a04"))))
+ (build-system go-build-system)
+ (arguments
+ ;; Arbitrary precision tests are known to be broken on aarch64, ppc64le
+ ;; and s390x. See: https://github.com/rcrowley/go-metrics/issues/249
+ `(#:tests? ,(not (string-prefix? "aarch64" (or (%current-target-system)
+ (%current-system))))
+ #:import-path "github.com/rcrowley/go-metrics"))
+ (propagated-inputs
+ (list go-github-com-stathat-go))
+ (synopsis "Go port of Coda Hale's Metrics library")
+ (description "This package provides a Go implementation of Coda Hale's
+Metrics library.")
+ (home-page "https://github.com/rcrowley/go-metrics")
+ (license license:bsd-2))))
+
(define-public go-github-com-skip2-go-qrcode
(package
(name "go-github-com-skip2-go-qrcode")
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index c5f590fb59..9d12a81df8 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -542,36 +542,6 @@ higher-level API for doing so.")
(home-page "https://github.com/stathat/go")
(license expat))))
-(define-public go-github-com-rcrowley-go-metrics
- (let ((commit "cac0b30c2563378d434b5af411844adff8e32960")
- (revision "2"))
- (package
- (name "go-github-com-rcrowley-go-metrics")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/rcrowley/go-metrics")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1hfxffnpaw49pr3wrkbzq3pnv3nyzsvk5dxndv0yz70xlrbg8a04"))))
- (build-system go-build-system)
- (arguments
- ;; Arbitrary precision tests are known to be broken on aarch64, ppc64le
- ;; and s390x. See: https://github.com/rcrowley/go-metrics/issues/249
- `(#:tests? ,(not (string-prefix? "aarch64" (or (%current-target-system)
- (%current-system))))
- #:import-path "github.com/rcrowley/go-metrics"))
- (propagated-inputs
- (list go-github-com-stathat-go))
- (synopsis "Go port of Coda Hale's Metrics library")
- (description "This package provides a Go implementation of Coda Hale's
-Metrics library.")
- (home-page "https://github.com/rcrowley/go-metrics")
- (license bsd-2))))
-
(define-public go-github-com-sasha-s-go-deadlock
(package
(name "go-github-com-sasha-s-go-deadlock")