summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-09-27 18:11:37 +0200
committerAndrew Tropin <andrew@trop.in>2023-09-28 09:38:27 +0400
commit3f7b091ea4897e3a170a54433a2476d3b6810dc4 (patch)
treee6e7c321cda7c6a64728053349cced6bf14f13c0
parent7c861ab4f46c1239ea2da4ef7b57deb88e2b2761 (diff)
gnu: emacs-buttercup: Remove phase fix-spy-on-test.
* gnu/packages/emacs-xyz.scm: (emacs-buttercup) [arguments](phases): Remove phase fix-spy-on-test, fixed in version 1.31. Signed-off-by: Andrew Tropin <andrew@trop.in>
-rw-r--r--gnu/packages/emacs-xyz.scm10
1 files changed, 0 insertions, 10 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2575a833ab..1340b00050 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28520,16 +28520,6 @@ targets the Emacs based IDEs (CIDER, ESS, Geiser, Robe, SLIME etc.)")
#:test-command #~(list "make" "test")
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'fix-spy-on-test
- (lambda _
- (substitute* "buttercup.el"
- ;; The spy-on test fails with native compilation, which was
- ;; fixed in v1.30 but with a variable name for Emacs newer
- ;; than 28.2. Add in the same fix with the current variable
- ;; name. Upstream bug and fix:
- ;; <https://github.com/jorgenschaefer/emacs-buttercup/issues/236>
- (("\\(native-comp-enable-subr-trampolines nil\\)" all)
- (string-append all " (comp-enable-subr-trampolines nil)")))))
(add-after 'install 'install-bin
(lambda _
(install-file "bin/buttercup"