summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author(unmatched-parenthesis <paren@disroot.org>2022-10-21 22:11:19 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-27 10:31:03 -0500
commit4118197603cab6bedad4172627e375913499a673 (patch)
treefee9ac7507531f5bca54212c7843ae3bc75dae0b
parent171f1918cafc6db94250a75d174acbdf4bd38cae (diff)
gnu: Add go-github-com-emersion-go-pgpmail.
* gnu/packages/golang.scm (go-github-com-emersion-go-pgpmail): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 75be734ef4..4dba288877 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10805,6 +10805,35 @@ text-only mail clients to display them.")
library geared towards parsing MIME encoded emails.")
(license license:expat)))
+(define-public go-github-com-emersion-go-pgpmail
+ (package
+ (name "go-github-com-emersion-go-pgpmail")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-pgpmail")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ar26b0apw5bxn58qfn1a79cxigbmrqm1irh1rb7x57fydihc7wm"))))
+ (build-system go-build-system)
+ (arguments
+ (list ;; tests don't support our version of protonmail/go-crypto; see
+ ;; <https://github.com/emersion/go-pgpmail/issues/12>
+ #:tests? #f
+ #:import-path "github.com/emersion/go-pgpmail"))
+ (propagated-inputs (list go-golang-org-x-text
+ go-golang-org-x-crypto
+ go-github-com-emersion-go-message
+ go-github-com-protonmail-go-crypto))
+ (home-page "https://github.com/emersion/go-pgpmail")
+ (synopsis "PGP mail encryption for Go")
+ (description
+ "The pgpmail package implements PGP encryption for e-mail messages.")
+ (license license:expat)))
+
(define-public go-github-com-gatherstars-com-jwz
(package
(name "go-github-com-gatherstars-com-jwz")