summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-05 16:37:51 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-04-05 16:37:51 +0300
commit413097306f2197fc8bd93ba084886a41f0e3fd52 (patch)
tree3dc74de09de36f92672568f482fb3c0465f46fc8
parentbbc4a8d238ee2f73ae3e16065fe4be4fd0e639aa (diff)
gnu: guile-3.0: Skip OOM test on powerpc-linux.
* gnu/packages/guile.scm (guile-3.0)[arguments]: Skip the OOM test on powerpc-linux also.
-rw-r--r--gnu/packages/guile.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 972a391a29..517cc0d13e 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -391,10 +391,11 @@ without requiring the source code to be rewritten.")
(("^GUILE_OPTIMIZATIONS.*")
"GUILE_OPTIMIZATIONS = -O1 -Oresolve-primitives -Ocps\n")))))
#~())
- #$@(if (target-ppc64le?)
+ #$@(if (target-powerpc?)
#~((add-after 'unpack 'skip-oom-test
(lambda _
- ;; This test hangs with guile-3.0.9 and libgc-8.2.2.
+ ;; This test hangs with guile-3.0.9 and libgc-8.2.2 and
+ ;; fails completely on powerpc-linux.
(substitute* "test-suite/standalone/test-out-of-memory"
(("!#") "!#\n\n(exit 77)\n")))))
#~())