summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:07 +0200
commit4267580a53e76e1ebbbe3ace7fcb3baa7620cb6f (patch)
treeb460eb02e5bf9535232d3492ddd0a6589bc02c02
parent1d837aaa32a3a2de8f4a1ac391f92effba50834e (diff)
gnu: tpacpi-bat: Update to 3.2.
* gnu/packages/linux.scm (tpacpi-bat): Update to 3.2. [arguments]: Don't explicitly return #t from phases. linux tpacpi-bat
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 39503de6ff..7f9a835d5f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6357,7 +6357,7 @@ from userspace.")
(define-public tpacpi-bat
(package
(name "tpacpi-bat")
- (version "3.1")
+ (version "3.2")
(source
(origin
(method git-fetch)
@@ -6366,7 +6366,7 @@ from userspace.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0wbaz34z99gqx721alh5vmpxpj2yxg3x9m8jqyivfi1wfpwc2nd5"))))
+ (base32 "0nd8s2bqbhl0sjpflphb4l9ix71p7kvnbvkq4dg9a1v0sxafyygm"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no test target
@@ -6380,8 +6380,7 @@ from userspace.")
;; tpacpi-bat modprobes the acpi_call kernel module if it's not
;; loaded. That's the administrator's prerogative; disable it.
(("system \"(modprobe .*)\"" _ match)
- (format #f "die \"Please run ‘~a’ first.\\n\"" match)))
- #t))
+ (format #f "die \"Please run ‘~a’ first.\\n\"" match)))))
(delete 'configure) ; nothing to configure
(delete 'build) ; nothing to build
(replace 'install
@@ -6396,8 +6395,7 @@ from userspace.")
(let ((target (string-append doc "/" file)))
(mkdir-p (dirname target))
(copy-recursively file target)))
- (list "battery_asl" "examples" "README.md"))
- #t))))))
+ (list "battery_asl" "examples" "README.md"))))))))
(inputs
(list perl))
(home-page "https://github.com/teleshoes/tpacpi-bat")