summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-07 15:32:40 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-02-09 21:53:42 +0100
commit43d4c2298143631ada19539314c99775c18747e7 (patch)
tree4c44e9d9aba5805997cd36bbe5993aedd22a591a
parent8771fc1715b400ead16f97683c67ad336b485750 (diff)
gnu: libevdev: Fix FTBFS with GCC7.
* gnu/packages/xorg.scm (libevdev)[arguments]: Add phase to please "gcc -pedantic".
-rw-r--r--gnu/packages/xorg.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index bf7a4050a3..15ebd380d4 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2402,6 +2402,18 @@ XC-APPGROUP, XTEST.")
(base32
"0xca343ff12wh6nsq76r0nbsfrm8dypjrzm4fqz9vv9v8i8kfrp1"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-before 'configure 'pedantry
+ (lambda _
+ ;; XXX: libevdev includes kernel headers, which causes this
+ ;; compile test to fail with:
+ ;; ...-headers-4.14.67/include/asm-generic/posix_types.h:88:14:
+ ;;error: ISO C90 does not support ‘long long’ [-Werror=long-long]
+ (substitute* "test/Makefile.in"
+ (("-pedantic -Werror -std=c89")
+ "-pedantic -Werror -std=c99"))
+ #t)))))
(native-inputs `(("python" ,python)))
(home-page "https://www.freedesktop.org/wiki/Software/libevdev/")
(synopsis "Wrapper library for evdev devices")