summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-04-02 23:39:32 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-04-02 23:39:32 +0300
commit451c1436a38a92d6903f78381f74c935a332ee87 (patch)
treeb1ec303f6533f0bbf02b6c888008c3c8d314b993
parent57818b6e3c2847e9103a06c3c96f88a9541197af (diff)
gnu: mc: Update to 4.8.16.
* gnu/packages/mc.scm (mc): Update to 4.8.16. [source]: Remove patch. * gnu/packages/patches/mc-fix-ncurses-build.patch: Remove. * gnu-system.am (dist_patch_DATA): Remove it.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/mc.scm8
-rw-r--r--gnu/packages/patches/mc-fix-ncurses-build.patch37
3 files changed, 4 insertions, 42 deletions
diff --git a/gnu-system.am b/gnu-system.am
index d45b3d1f0f..d883cdc207 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -623,7 +623,6 @@ dist_patch_DATA = \
gnu/packages/patches/mars-sfml-2.3.patch \
gnu/packages/patches/matplotlib-setupext-tk.patch \
gnu/packages/patches/maxima-defsystem-mkdir.patch \
- gnu/packages/patches/mc-fix-ncurses-build.patch \
gnu/packages/patches/mcron-install.patch \
gnu/packages/patches/mdadm-gcc-4.9-fix.patch \
gnu/packages/patches/mhash-keygen-test-segfault.patch \
diff --git a/gnu/packages/mc.scm b/gnu/packages/mc.scm
index 6e3747c943..43dab8ff41 100644
--- a/gnu/packages/mc.scm
+++ b/gnu/packages/mc.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,7 +34,7 @@
(define-public mc
(package
(name "mc")
- (version "4.8.11")
+ (version "4.8.16")
(source
(origin
(method url-fetch)
@@ -41,8 +42,7 @@
version ".tar.xz"))
(sha256
(base32
- "0flrw5pq2mg2d39bh6dllndhpcfppjza6g70p4ry2wcx9y2flxqq"))
- (patches (list (search-patch "mc-fix-ncurses-build.patch")))))
+ "083h5gwc0nny9b557way5dsmj71g2bzkiai4bn30y5nkjwqbxg5v"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)
("perl" ,perl)))
@@ -63,4 +63,4 @@ copying and moving, Midnight Commander also supports viewing the contents of
RPM package files and other archives and managing files on other computers via
FTP or FISH. It also includes a powerful text editor for opening text
files.")
- (license gpl2)))
+ (license gpl3+)))
diff --git a/gnu/packages/patches/mc-fix-ncurses-build.patch b/gnu/packages/patches/mc-fix-ncurses-build.patch
deleted file mode 100644
index c583c92e10..0000000000
--- a/gnu/packages/patches/mc-fix-ncurses-build.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-Patch cherry-picked from resolution of
-http://www.midnight-commander.org/ticket/3114
-
---- a/lib/tty/key.c (revision 0ed4a91d7df4e50512defd2e0734ecab7c9da07f)
-+++ b/lib/tty/key.c (revision d870aedad1907773f8586fe818a89e6b5178b849)
-@@ -1947,4 +1947,5 @@
- {
- int c;
-+ int flag = 0; /* Return value from select */
- #ifdef HAVE_LIBGPM
- static struct Gpm_Event ev; /* Mouse event */
-@@ -1979,5 +1980,4 @@
- {
- int nfd;
-- static int flag = 0; /* Return value from select */
- fd_set select_set;
-
---- a/lib/tty/tty-ncurses.c (revision bb65b467900ea9eb1f7867c059fd26fac86c747c)
-+++ b/lib/tty/tty-ncurses.c (revision d870aedad1907773f8586fe818a89e6b5178b849)
-@@ -50,4 +50,5 @@
- #include "tty.h"
- #include "color-internal.h"
-+#include "key.h"
- #include "mouse.h"
- #include "win.h"
-@@ -531,4 +532,5 @@
- {
- int res;
-+ unsigned char str[UTF8_CHAR_LEN + 1];
-
- res = g_unichar_to_utf8 (c, (char *) str);
-@@ -541,5 +543,4 @@
- else
- {
-- unsigned char str[UTF8_CHAR_LEN + 1];
- const char *s;
-