summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-02-04 13:40:29 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-18 12:34:48 +0000
commit4724d745c16efc28c37f47ffbbbe227e9f0ea53e (patch)
treeb6529306b85b4e73f2d4dd78cb3db50506585644
parent5e4114284807f8a48888cb6206729e4f27fba785 (diff)
gnu: node-path-key: Move package in alphabetical order.
* gnu/packages/node-xyz.scm (node-path-key): Move package in alphabetical order. Change-Id: I33d737668063c13f6cd369f8d922eb1aa02f7177 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/node-xyz.scm52
1 files changed, 26 insertions, 26 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 47c1244674..e6858db1f4 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -827,6 +827,32 @@ if desired.")
while being as light-weight and simple as possible.")
(license license:expat))))
+(define-public node-path-key
+ (package
+ (name "node-path-key")
+ (version "4.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sindresorhus/path-key")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09f4rf70qhq234fcc3pw9nrqic8cb75pk2b6wfnpr96v0r1h8d8g"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases (modify-phases %standard-phases
+ (add-after 'patch-dependencies 'delete-dependencies
+ (lambda _
+ (delete-dependencies '("@types/node" "ava" "tsd" "xo")))))))
+ (home-page "https://github.com/sindresorhus/path-key")
+ (synopsis "Cross-platform utility to compute the PATH environment variable key")
+ (description "@code{path-key} provides an implementation to compute the
+particular cross-platform spellings of the PATH environment variable key.")
+ (license license:expat)))
+
(define-public node-pbf
(package
(name "node-pbf")
@@ -1365,32 +1391,6 @@ function with browser support.")
(description "@code{wrappy} is a utility for Node.js to wrap callbacks.")
(license license:isc)))
-(define-public node-path-key
- (package
- (name "node-path-key")
- (version "4.0.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/sindresorhus/path-key")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "09f4rf70qhq234fcc3pw9nrqic8cb75pk2b6wfnpr96v0r1h8d8g"))))
- (build-system node-build-system)
- (arguments
- '(#:tests? #f
- #:phases (modify-phases %standard-phases
- (add-after 'patch-dependencies 'delete-dependencies
- (lambda _
- (delete-dependencies '("@types/node" "ava" "tsd" "xo")))))))
- (home-page "https://github.com/sindresorhus/path-key")
- (synopsis "Cross-platform utility to compute the PATH environment variable key")
- (description "@code{path-key} provides an implementation to compute the
-particular cross-platform spellings of the PATH environment variable key.")
- (license license:expat)))
-
(define-public node-serialport-binding-abstract
(package
(name "node-serialport-binding-abstract")