summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSughosha <sughosha@disroot.org>2024-06-05 21:22:08 +0530
committerLudovic Courtès <ludo@gnu.org>2024-06-13 10:56:42 +0200
commit47e909a55408844923b6cb073ebbf25b77b9c2ca (patch)
treefefe89a8fbfe00cb4932810b78d80e444aab5a3e
parentdc5da408ec1b00d176c8cfa5021fc2b33a7a8e12 (diff)
gnu: Add python-pymarshal.
* gnu/packages/python-xyz.scm (python-pymarshal): New variable. Change-Id: I6a1d2f8f21869856a9a227bed213d9f71204b2d4 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4b09f49cc0..556606b6b4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4485,6 +4485,30 @@ type hints and parse from command line, config files and environment
variables.")
(license license:expat)))
+(define-public python-pymarshal
+ (package
+ (name "python-pymarshal")
+ (version "2.2.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pymarshal" version))
+ (sha256
+ (base32
+ "1lhb7yim60pvclbd440zd4n50xs1d2rvmnrhhvib3hyv0dxil5j3"))))
+ (build-system pyproject-build-system)
+ (arguments
+ ;; Test fails with this error:
+ ;; "CovReportWarning: Failed to generate report: No data to report."
+ (list #:tests? #f))
+ (native-inputs
+ (list python-pytest python-pytest-cov))
+ (propagated-inputs (list python-bson python-pyyaml))
+ (home-page "https://gitlab.com/d3v-t00lz/pymarshal")
+ (synopsis "Pythonic implementation of Golang struct (un)marshalling")
+ (description "PyMarshal replicates the feature of (un)marshalling structs
+in Golang.")
+ (license license:bsd-2)))
+
(define-public python-simplejson
(package
(name "python-simplejson")