summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-05 18:17:12 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-04-05 21:58:06 +0300
commit48f0da4f4da000f9ed6a4705e4dabbdba7344d05 (patch)
treeadf7298635d9837570931f845b60029c4af86ca1
parent451dff61292ec635317a4482a464c5c4e5e5820c (diff)
gnu: go-1.19: Skip 2 gccgo tests.
* gnu/packages/golang.scm (go-1.19)[arguments]: Add a phase to skip two tests depending on specific versions of gccgo.
-rw-r--r--gnu/packages/golang.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 23aa54c330..d22fe556d3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -905,6 +905,17 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(substitute-keyword-arguments (package-arguments go-1.18)
((#:phases phases)
#~(modify-phases #$phases
+ ;; These are recurring test failures, depending on having a new
+ ;; enough version of gccgo. gccgo-12.2 fails with go-1.19.7.
+ ;; https://github.com/golang/go/issues/22224
+ ;; https://github.com/golang/go/issues/25324
+ (add-after 'unpack 'skip-TestGoPathShlibGccgo-tests
+ (lambda _
+ (substitute* "misc/cgo/testshared/shared_test.go"
+ (("TestGoPathShlibGccgo.*" all)
+ (string-append all "\n t.Skip(\"golang.org/issue/22224\")\n"))
+ (("TestTwoGopathShlibsGccgo.*" all)
+ (string-append all "\n t.Skip(\"golang.org/issue/22224\")\n")))))
(replace 'install-doc-files
(lambda _
(for-each (lambda (file)