summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-05-03 08:53:11 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-31 20:20:21 +0100
commit49b696cb588bfc1e7b1eaaeed7e819d0666b7862 (patch)
treebd60b5127af32207f662fb2afd4bf8d53e63e9a2
parent3d16f748fb328a90c9c4c6a4bae92d4f952f616c (diff)
gnu: Add r-airpart.
* gnu/packages/bioconductor.scm (r-airpart): New variable.
-rw-r--r--gnu/packages/bioconductor.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 6ec177d222..7ece87aa7f 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2082,6 +2082,53 @@ using the linear model features implemented in limma. Standard Bioconductor
objects are used so that other packages could be used as well.")
(license license:gpl3)))
+(define-public r-airpart
+ (package
+ (name "r-airpart")
+ (version "1.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "airpart" version))
+ (sha256
+ (base32
+ "0ljankgvgf8rby4z340wxx8v7acs9yz955p3a40jl6y8rz1svc06"))))
+ (properties `((upstream-name . "airpart")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-apeglm
+ r-clue
+ r-complexheatmap
+ r-dplyr
+ r-dynamictreecut
+ r-emdbook
+ r-forestplot
+ r-ggplot2
+ r-lpsolve
+ r-matrixstats
+ r-mclust
+ r-pbapply
+ r-plyr
+ r-rcolorbrewer
+ r-rlang
+ r-s4vectors
+ r-scater
+ r-singlecellexperiment
+ r-smurf
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/airpart")
+ (synopsis "Differential cell-type-specific allelic imbalance")
+ (description
+ "The airpart package identifies sets of genes displaying differential
+cell-type-specific allelic imbalance across cell types or states, utilizing
+single-cell allelic counts. It makes use of a generalized fused lasso with
+binomial observations of allelic counts to partition cell types by their
+allelic imbalance. Alternatively, a nonparametric method for partitioning
+cell types is offered. The package includes a number of visualizations and
+quality control functions for examining single cell allelic imbalance
+datasets.")
+ (license license:gpl2)))
+
(define-public r-amountain
(package
(name "r-amountain")