summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-11-03 01:48:12 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-11-03 03:10:54 +0100
commit4b63373ea4a7067dd51eb964ac8dad8d3105fafa (patch)
treeaf2ddc2bb555cc41bdcf6f9e1483af2b369e9ca6
parent012ee8c25556e84a98cce76c10d2e20b63d1c6ba (diff)
gnu: proxychains-ng: Update to 4.15.
* gnu/packages/networking.scm (proxychains-ng): Update to 4.15. [arguments]: Don't explicitly return #t from phases.
-rw-r--r--gnu/packages/networking.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 5d23b34c9a..f6c020864f 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2260,14 +2260,14 @@ libproxy only have to specify which proxy to use.")
(define-public proxychains-ng
(package
(name "proxychains-ng")
- (version "4.14")
+ (version "4.15")
(source
(origin
(method url-fetch)
(uri (string-append "http://ftp.barfooze.de/pub/sabotage/tarballs/"
"proxychains-ng-" version ".tar.xz"))
(sha256
- (base32 "1bmhfbl1bzc87vl0xwr1wh5xvslfyc41nl2hqzhbj258p0sy004x"))))
+ (base32 "10ch6rmbw2lwrq1bc9w4glxkws7hvsy5ihasvzf3yg053xzsn1rj"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; there are no tests
@@ -2280,8 +2280,7 @@ libproxy only have to specify which proxy to use.")
(substitute* "configure"
(("\\*\\) break ;;" line)
(string-append "[A-Z]*) shift ;;\n"
- line)))
- #t))
+ line)))))
(add-before 'configure 'set-up-environment
(lambda _
(setenv "CC" "gcc")