summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVasilii Smirnov <vasilii.smirnov@mailbox.org>2024-04-28 09:27:45 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-04-28 10:11:25 -0400
commit4c81c1f734ee2979f42671cb15fe83be64c06b6c (patch)
treea55a0bb08ae897aa3b186d95aa82014a6e708ff6
parent2205660ce2f78ae608c28de8d289b7848464928b (diff)
gnu: hashlink: Update to 1.14
Change-Id: I1fe593cc03675cce81f70efb2576ff7bcd374187 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/haxe.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/haxe.scm b/gnu/packages/haxe.scm
index 6fd108abd5..c7af07325f 100644
--- a/gnu/packages/haxe.scm
+++ b/gnu/packages/haxe.scm
@@ -196,7 +196,7 @@ includes the compiler and library manager.")
(define-public hashlink
(package
(name "hashlink")
- (version "1.12")
+ (version "1.14")
(source
(origin
(method git-fetch)
@@ -205,7 +205,7 @@ includes the compiler and library manager.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0i5f1mxpgjcdirx60kxrw0r0y15qh3j16a6fj8mzkq3k7j2hc982"))
+ (base32 "163kj2fww8a1hp93aklla181sp84hrsl8dy5rwrv79057bmkjz5d"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -233,7 +233,7 @@ includes the compiler and library manager.")
(lambda _
(substitute* "Makefile"
(("\\$\\{PCRE\\}") "")
- (("-lpthread") "-lpthread -lpcre16")
+ (("-lpthread") "-lpthread -lpcre2-16")
(("include/minimp3")
(string-append #$(this-package-input "minimp3") "/include"))
(("include/mikktspace ")
@@ -260,7 +260,7 @@ includes the compiler and library manager.")
mikktspace
minimp3
openal
- pcre
+ pcre2
sdl2
sqlite
zlib))