summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-09-07 23:32:14 +0100
committerChristopher Baines <mail@cbaines.net>2023-09-27 12:07:18 +0100
commit4cef9cb160ce2e88d42e93d22d43bf0739d13e79 (patch)
tree62ba7443ac2fb4d144bb485afcb2f908d34dbdf9
parent03c7b82cf6bcaf5492ad7e457b956df4303e520e (diff)
gnu: python-cdflib: Fix version detection.
* gnu/packages/astronomy.scm (python-cdflib): Fix version detection during build Wheel package. [arguments]: Add new phase 'set-env-version. [native-inputs]: Add python-setuptools-scm. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/astronomy.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 95b29ec2ea..335c075a68 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1657,6 +1657,10 @@ bad pixel tracking throughout the reduction process.")
(arguments
(list #:phases
#~(modify-phases %standard-phases
+ (add-before 'build 'set-env-version
+ (lambda _
+ (setenv "SETUPTOOLS_SCM_PRETEND_VERSION"
+ #$version)))
(add-before 'check 'set-home-env
(lambda _
(setenv "HOME" (getcwd)))))))
@@ -1668,6 +1672,7 @@ bad pixel tracking throughout the reduction process.")
python-pytest
python-pytest-cov
python-pytest-remotedata
+ python-setuptools-scm
python-xarray))
(home-page "https://github.com/MAVENSDC/cdflib")
(synopsis "Python library to deal with NASA's CDF astronmical data format")