summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-04-20 06:44:07 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-24 13:59:22 +0100
commit4e2b6d5585cc5ab103003cfc7a2f74dff548edfb (patch)
tree159c2d933fdc9b2bf5f20a018534d7a1d532646d
parente2ba93373a29ddf5d5754368957e89f3b426bb0a (diff)
gnu: Add go-golang-org-x-exp-2023.
* gnu/packages/golang-build.scm (go-golang-org-x-exp-2023): New variable. Change-Id: Ibcbeee0567ac92d4050329273e585316ee726df0 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-build.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 04267845a5..e13ce3afa8 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -133,6 +133,22 @@ for the Go language.")
@code{old} directory) packages.")
(license license:bsd-3)))
+;; It's for the Kubo update; remove it when it is no longer needed.
+(define-public go-golang-org-x-exp-2023
+ (package
+ (inherit go-golang-org-x-exp)
+ (name "go-golang-org-x-exp")
+ (version "0.0.0-20230725012225-302865e7556b")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/exp")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fkmi0zjwv70n9d9q9bmzch2zvf7xm3d65qh63zll6dljq2lh4b8"))))))
+
(define-public go-golang-org-x-image
(let ((commit "58c23975cae11f062d4b3b0c143fe248faac195d")
(revision "1"))