summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 15:15:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:36 +0200
commit4ea050858f9d059b8e0bcb47c9ddb2a40ccd1f55 (patch)
tree573f0a44f0cec3702f0b519c9258d2c7b280b5b6
parent30b7a6393eec55eb9453f4cbe60b67c629a86339 (diff)
gnu: Add texlive-spacekern.
* gnu/packages/tex.scm (texlive-spacekern): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b044020353..98481761b3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13881,6 +13881,26 @@ exactly to the respective kerning value. By option the bars can be placed
behind or in front of the glyphs. The package requires LuaLaTeX.")
(license license:lppl1.3c)))
+(define-public texlive-spacekern
+ (package
+ (name "texlive-spacekern")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/spacekern/"
+ "tex/lualatex/spacekern/")
+ (base32
+ "0rmdg9daqp0fallznsqsr0475z7cw0djhxq6dwkyk5yg8ii9c6s9")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/spacekern")
+ (synopsis "Kerning between words and against space")
+ (description
+ "This package provides two shorthands for typesetting breaking and
+non-breaking small spaces, where both hyphenation and kerning against space
+are correctly applied. Additionally, interword kerning can be applied.")
+ (license license:lppl1.3c)))
+
(define-public texlive-standalone
(package
(name "texlive-standalone")