summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 15:18:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:38 +0200
commit4ee871537b899af7401db3f731254342619682ab (patch)
tree86b3f59d1a423ba084bb15047cac269636b36169
parente331b8731748804faba177be493e37063682f48c (diff)
gnu: Add texlive-typewriter.
* gnu/packages/tex.scm (texlive-typewriter): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4e75bcd2b9..3c4a1e219d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14201,6 +14201,26 @@ plain LuaTeX. It also supports (non-quoted) comma-separated values, or indeed
values separated by any character.")
(license license:eupl1.2)))
+(define-public texlive-typewriter
+ (package
+ (name "texlive-typewriter")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/typewriter/"
+ "tex/lualatex/typewriter/")
+ (base32
+ "00c53vbm8fchjggi3h1w49y07ma4cmmliqx2bhkvis6qsqgddw5f")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/typewriter")
+ (synopsis "Typeset with a randomly variable monospace font")
+ (description
+ "The typewriter package uses the OpenType Computer Modern Unicode
+Typewriter font, together with a LuaTeX virtual font setup that introduces
+random variability in grey level and angle of each character.")
+ (license license:lppl)))
+
(define-public texlive-units
(package
(name "texlive-units")