summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-09-08 16:56:56 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-09-10 09:36:58 +0200
commit4f134f26fd9e4feb799b21157424af216be3d267 (patch)
treed602d68e085a244dfeb2971cc0ab6a5577dc60f4
parentbcca8332ff778e115323a4d0b00928bfa20f7584 (diff)
gnu: Add r-ggalt.
* gnu/packages/cran.scm (r-ggalt): New variable.
-rw-r--r--gnu/packages/cran.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 471b5b1eb5..81fa0f7b5b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -422,6 +422,49 @@ Gaussian quadrature for a numerical solution.")
Distance (EMD).")
(license license:expat)))
+(define-public r-ggalt
+ (package
+ (name "r-ggalt")
+ (version "0.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "ggalt" version))
+ (sha256
+ (base32
+ "0ssa274d41vhd6crzjz7jqzbwgnjimxwxl23p2cx35aqs5wdfjpc"))))
+ (properties `((upstream-name . "ggalt")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-ash
+ r-dplyr
+ r-extrafont
+ r-ggplot2
+ r-gtable
+ r-kernsmooth
+ r-maps
+ r-mass
+ r-plotly
+ r-proj4
+ r-rcolorbrewer
+ r-scales
+ r-tibble))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/hrbrmstr/ggalt")
+ (synopsis
+ "Geometries, coordinate systems, fonts and more for ggplot2")
+ (description
+ "This package provides a compendium of new geometries, coordinate systems,
+statistical transformations, scales and fonts for ggplot2, including splines,
+1d and 2d densities, univariate average shifted histograms, a new map
+coordinate system based on the PROJ.4-library along with
+@code{geom_cartogram()} that mimics the original functionality of
+@code{geom_map()}, formatters for \"bytes\", a @code{stat_stepribbon()}
+function, increased @code{plotly} compatibility and the @code{StateFace} open
+source font ProPublica. Further new functionality includes lollipop charts,
+dumbbell charts, the ability to encircle points and coordinate-system-based
+text annotations.")
+ (license license:agpl3)))
+
(define-public r-glmpca
(package
(name "r-glmpca")