summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-04-19 20:59:45 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-06-03 19:56:29 +0200
commit5105b07d479f788a93d125349769b0c2ffc4c6db (patch)
treec22d172c894873d4fae6a35d985ebcf8ff91b849
parent6b09647babb50fbefaf01872c6e688f48d850e21 (diff)
gnu: webkitgtk: Update to 2.44.1.
* gnu/packages/webkit.scm (webkitgtk): Update to 2.44.1. [#:configure-flags]: Add “-DUSE_LIBBACKTRACE=OFF”. [#:phases]: Refer to $prefix/share/doc instead of the now unused $prefix/share/gtk-doc. (webkitgtk-for-gtk3)[#:configure-flags]: Add 0“-DUSE_GTK4=OFF”. Retain “-DENABLE_INTROSPECTION=ON”.
-rw-r--r--gnu/packages/webkit.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index bf24a65e83..2e10093a68 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -127,13 +127,13 @@ engine that uses Wayland for graphics output.")
(define-public webkitgtk
(package
(name "webkitgtk")
- (version "2.42.5")
+ (version "2.44.1")
(source (origin
(method url-fetch)
(uri (string-append "https://www.webkitgtk.org/releases/"
name "-" version ".tar.xz"))
(sha256
- (base32 "0jg7c7z572afywwrnvdj3m5agaviv0vkqmzznnzzv30byb0phhmn"))
+ (base32 "0qamkk9db8m6x4qv5y10lihc18yzgrgbn6ldqw00ckghn1ci8ns2"))
(snippet
#~(begin
(use-modules (guix build utils))
@@ -162,6 +162,7 @@ engine that uses Wayland for graphics output.")
;; tool to validate the good operation of
;; webkitgtk.
"-DENABLE_MINIBROWSER=ON"
+ "-DUSE_LIBBACKTRACE=OFF" ; XXX: circular dependency
;; The default lib installation prefix is lib64.
(string-append "-DLIB_INSTALL_DIR=" #$output "/lib")
;; XXX: WebKitGTK makes use of elogind's systemd-compatible
@@ -222,8 +223,8 @@ engine that uses Wayland for graphics output.")
(lambda* (#:key outputs #:allow-other-keys)
(let ((doc (assoc-ref outputs "doc")))
(mkdir-p (string-append doc "/share"))
- (rename-file (string-append #$output "/share/gtk-doc")
- (string-append doc "/share/gtk-doc"))))))))
+ (rename-file (string-append #$output "/share/doc")
+ (string-append doc "/share/doc"))))))))
(native-inputs
(list bison
gettext-minimal
@@ -295,9 +296,8 @@ propagated by default) such as @code{gst-plugins-good} and
(arguments
(substitute-keyword-arguments (package-arguments webkitgtk)
((#:configure-flags flags)
- #~(cons* "-DENABLE_GTKDOC=ON"
- (delete "-DENABLE_INTROSPECTION=ON"
- (delete "-DUSE_GTK4=ON" #$flags))))))
+ #~(cons* "-DUSE_GTK4=OFF"
+ (delete "-DUSE_GTK4=ON" #$flags)))))
(propagated-inputs
(modify-inputs (package-propagated-inputs webkitgtk)
(replace "gtk" gtk+)))