summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-06-03 08:27:39 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-06-03 08:27:39 +0200
commit51f2fe6542009e744486aac6b0691042691ac37a (patch)
tree25a872bc37420f17e82a75ba4531926da87727c5
parentc11b92a8aae6fe7fad0da8257ec28f5009c37b35 (diff)
gnu: Add r-consrank.
* gnu/packages/cran.scm (r-consrank): New variable.
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 688621343e..1f6b18f7d4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -31900,6 +31900,33 @@ a Huber regression warm start. Confidence intervals for regression
coefficients are constructed using multiplier bootstrap.")
(license license:gpl3)))
+(define-public r-consrank
+ (package
+ (name "r-consrank")
+ (version "2.1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "ConsRank" version))
+ (sha256
+ (base32
+ "0v1dr7zj2fpgncymakv5qszdrlqzvc5zxfyc3yrsj09gbm0gvyby"))))
+ (properties `((upstream-name . "ConsRank")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-gtools r-proxy r-rgl r-rlist r-tidyr))
+ (home-page "https://www.r-project.org/")
+ (synopsis
+ "Compute median rankings according to Kemeny's axiomatic approach")
+ (description
+ "This package lets you compute the median ranking according to Kemeny's
+axiomatic approach. Rankings can or cannot contain ties, rankings can be both
+complete or incomplete. The package contains both branch-and-bound algorithms
+and heuristic solutions recently proposed. The searching space of the
+solution can either be restricted to the universe of the permutations or
+unrestricted to all possible ties. The package also provides some useful
+utilities for deal with preference rankings, including both element-weight
+Kemeny distance and correlation coefficient.")
+ (license license:gpl3)))
+
(define-public r-fastshap
(package
(name "r-fastshap")