summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-12-09 22:16:30 +0100
committerAndreas Enge <andreas@enge.fr>2013-12-09 22:16:30 +0100
commit56aa03b0c2804ca8694d094b038f47299651fd09 (patch)
tree6ee9ee0893ab21b4df615c792e07a43e79643867
parent15974e63585bec566b5fd220f26776998dad3adb (diff)
gnu: Add perl-file-listing.
* gnu/packages/web.scm (perl-file-listing): New variable.
-rw-r--r--gnu/packages/web.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 390ace8f69..37c764c59e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -342,3 +342,25 @@ Net::HTTP class represents a connection to an HTTP server. The HTTP protocol
is described in RFC 2616. The Net::HTTP class supports HTTP/1.0 and
HTTP/1.1.")
(home-page "http://search.cpan.org/~gaas/Net-HTTP/")))
+
+(define-public perl-file-listing
+ (package
+ (name "perl-file-listing")
+ (version "6.04")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/G/GA/GAAS/File-Listing-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1xcwjlnxaiwwpn41a5yi6nz95ywh3szq5chdxiwj36kqsvy5000y"))))
+ (build-system perl-build-system)
+ (inputs
+ `(("perl-http-date" ,perl-http-date)))
+ (license (package-license perl))
+ (synopsis "Perl directory listing parser")
+ (description
+ "The File::Listing module exports a single function called parse_dir(),
+which can be used to parse directory listings.")
+ (home-page "http://search.cpan.org/~gaas/File-Listing/")))