summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-22 21:20:09 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-11 21:56:54 +0200
commit59a972885c831ad0f6043a7d000ff40b28f690a8 (patch)
tree16ed6d92b0b6539876e39e0c29f5c93dbbda9cb7
parent047160f2f1620d33b8de362cbbd6ee0bb52d93c0 (diff)
gnu: Add python-pytest-warnings.
* gnu/packages/python.scm (python-pytest-warnings, python2-pytest-warnings): New variables.
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2e6af1cfec..6228f643ca 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14141,3 +14141,27 @@ for Flask.")
(define-public python2-mwclient
(package-with-python2 python-mwclient))
+
+(define-public python-pytest-warnings
+ (package
+ (name "python-pytest-warnings")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-warnings" version))
+ (sha256
+ (base32
+ "0gf2dpahpl5igb7jh1sr9acj3z3gp7zahqdqb69nk6wx01c8kc1g"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("pytest" ,python-pytest-3.0)))
+ (home-page "https://github.com/fschulze/pytest-warnings")
+ (synopsis "Pytest plugin to list Python warnings in pytest report")
+ (description
+ "Python-pytest-warnings is a pytest plugin to list Python warnings in
+pytest report.")
+ (license license:expat)))
+
+(define-public python2-pytest-warnings
+ (package-with-python2 python-pytest-warnings))