summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 15:10:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:33 +0200
commit59befed247b169905bc5f51430e082df39fa101c (patch)
tree8dbffebf0735efa71b5efd498866950321c0f4cf
parent7898ba2b5d97d0302722738f3770aaeafc12c58c (diff)
gnu: Add texlive-pdfextra.
* gnu/packages/tex.scm (texlive-pdfextra): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 605acbb98f..21ba24c319 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11769,6 +11769,29 @@ underlining, and striking out, and crossing out.")
with LuaLaTeX.")
(license license:expat)))
+(define-public texlive-pdfextra
+ (package
+ (name "texlive-pdfextra")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/optex/pdfextra/" "tex/luatex/pdfextra/"
+ "tex/optex/pdfextra/")
+ (base32
+ "0vv7vidcvi6c9bg9rdp00d324d3xfyazpwlc7l4vggz1w6n8l96y")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pdfextra")
+ (synopsis "Extra PDF features for (Op)TeX")
+ (description
+ "This package provides extra PDF features for OpTeX (or in limited form
+for plain LuaTeX and LuaLaTeX). As a minimalistic format, OpTeX does not
+support advanced features of the PDF file format in its base. This third
+party package aims to provide them. As such, it supports insertion of
+multimedia (audio, video, 3D), hyperlinks and other actions, triggering
+events, transitions, and attachments.")
+ (license license:bsd-0)))
+
(define-public texlive-pgf
(package
(name "texlive-pgf")