summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-03-09 16:49:55 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-03-09 19:54:34 -0500
commit59ff9d008816a7d04cdd50d0db371ae1223e3329 (patch)
tree215a6efa0752b3f4515fd26d3c2342aff6f7e581
parentd8c9d27ffbc600aa04ecf933aad84c90b9869f1a (diff)
gnu: qttools-5: Patch path to qmake for the lprodump command.
This previously would lead to this cryptic error: "WARNING: Could not find qmake spec 'default'", which turned out to be caused by lprodump erroneously attempting to run 'qmake' from its own prefix (qmake is from the qtbase package, not qttools). * gnu/packages/qt.scm (qttools-5) [phases] <patch-qmake>: New phase. Change-Id: I6e9a2d35fec987451fd1e30b84a82023dbfd3316
-rw-r--r--gnu/packages/qt.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 761d12e31f..72c36513e9 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2171,7 +2171,18 @@ plugin for Adobe After Effects.")
"1bkx2sc5hyldarc7w76ymv7dlcna3ib9r2kp67jdqcf856bnrx36"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg-5)
- ((#:tests? _ #f) #f))) ; TODO: Enable the tests
+ ((#:tests? _ #f) #f) ; TODO: Enable the tests
+ ((#:phases phases '%standard-phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'patch-qmake
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Adjust the default location of the 'qmake' command known to
+ ;; the 'lprodump' command, which would otherwise look for it
+ ;; in its own bindir.
+ (substitute* "src/linguist/lprodump/main.cpp"
+ (("app.applicationDirPath\\() \\+ QLatin1String\\(\"/qmake\")")
+ (format #f "QLatin1String(~s)"
+ (search-input-file inputs "bin/qmake"))))))))))
(native-inputs (list perl qtdeclarative-5 vulkan-headers))
(inputs (list mesa qtbase-5))
(synopsis "Qt Tools and Designer modules")