summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2023-11-09 19:38:17 +0000
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:59:47 +0200
commit5bbacd11393a8ecc4a5147d5cfdeaefecf058fc5 (patch)
tree51fef6669733101fd7d74d729d06d29f5b4a2997
parent375518b3ee8d9f28bb55e22f757ce6a3fbb7b68d (diff)
gnu: Add rust-gix-traverse-0.33.
* gnu/packages/crates-io.scm (rust-gix-traverse-0.33): New variable. (rust-gix-traverse-0.26): Inherit from rust-gix-traverse-0.33. Change-Id: I0cdf6eb9261e8237dd95afa4bf11c4dbe6ac4fe4 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm35
1 files changed, 29 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 417e5854b5..5140be1943 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -31929,8 +31929,36 @@ can be turned off to zero cost.")
implementing the git transport layer.")
(license (list license:expat license:asl2.0))))
+(define-public rust-gix-traverse-0.33
+ (package
+ (name "rust-gix-traverse")
+ (version "0.33.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "gix-traverse" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "180vp1piwlalsv8qkmmif03l7h2kdxfx5vawkclbmb236smh9vr2"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-gix-commitgraph" ,rust-gix-commitgraph-0.21)
+ ("rust-gix-date" ,rust-gix-date-0.8)
+ ("rust-gix-hash" ,rust-gix-hash-0.13)
+ ("rust-gix-hashtable" ,rust-gix-hashtable-0.4)
+ ("rust-gix-object" ,rust-gix-object-0.37)
+ ("rust-gix-revwalk" ,rust-gix-revwalk-0.8)
+ ("rust-smallvec" ,rust-smallvec-1)
+ ("rust-thiserror" ,rust-thiserror-1))))
+ (home-page "https://github.com/Byron/gitoxide")
+ (synopsis "Ways to traverse Git commit graphs and trees for Gix")
+ (description "Part of Gitoxide, a pure Rust implementation of Git. This
+package is used to traverse Git commit graphs and trees.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-gix-traverse-0.26
(package
+ (inherit rust-gix-traverse-0.33)
(name "rust-gix-traverse")
(version "0.26.0")
(source
@@ -31940,17 +31968,12 @@ implementing the git transport layer.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "1n9kgzw5jal2jsqb56bpaj1xp35zp2hz6nf5klrjdgxl9jc2x15h"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-gix-hash" ,rust-gix-hash-0.11)
("rust-gix-hashtable" ,rust-gix-hashtable-0.2)
("rust-gix-object" ,rust-gix-object-0.30)
- ("rust-thiserror" ,rust-thiserror-1))))
- (home-page "https://github.com/Byron/gitoxide")
- (synopsis "Crate of the gitoxide project")
- (description "This package provides a crate of the gitoxide project.")
- (license (list license:expat license:asl2.0))))
+ ("rust-thiserror" ,rust-thiserror-1))))))
(define-public rust-gix-url-0.19
(package