summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2023-04-17 21:44:10 +0900
committerLudovic Courtès <ludo@gnu.org>2023-06-08 23:33:39 +0200
commit5e0b8d51b87bed97a07f3a7c70cf41c92473fd71 (patch)
treec91a9bd4a7d6530ebd231d3dd0fe785771af23ab
parentaceb150d29832e824446b29fab821acda50531ff (diff)
gnu: Add ruby-minima.
I added a test by `jekyll build`. * gnu/packages/ruby.scm (ruby-minima): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/ruby.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index eb84367d15..f28ad97e11 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2022, 2023 Remco van 't Veer <remco@remworks.net>
;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
+;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5258,6 +5259,36 @@ client protocol.")
(home-page "https://github.com/net-ssh/net-scp")
(license license:expat)))
+(define-public ruby-minima
+ (package
+ (name "ruby-minima")
+ (version "2.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "minima" version))
+ (sha256
+ (base32
+ "1gk7jmriiswda1ykjzpsw9cpiya4m9n0yrh0h6xnrc8zcfy543jj"))))
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "jekyll" "build"))
+ ;; Without the following, an attempt to remove
+ ;; minima-<version>.gem is made during installation,
+ ;; which will fail.
+ (delete-file #$(string-append "_site/minima-"
+ version ".gem")))))))
+ (build-system ruby-build-system)
+ (propagated-inputs (list jekyll ruby-jekyll-feed ruby-jekyll-seo-tag))
+ (synopsis "Beautiful, minimal theme for Jekyll")
+ (description
+ "Minima is a one-size-fits-all Jekyll theme for writers. It's Jekyll's
+default (and first) theme. It's what you get when you run @code{jekyll new}.")
+ (home-page "https://github.com/jekyll/minima")
+ (license license:expat)))
+
(define-public ruby-minitest
(package
(name "ruby-minitest")