summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2022-08-31 12:44:22 -0400
committerMathieu Othacehe <othacehe@gnu.org>2022-09-11 16:43:31 +0200
commit5ed679a2a91d84b2f651290a0a98fd5c0352f943 (patch)
tree5021a0899338834e5f144062eae17210d9b348f5
parentbf0708d2678df34691056b6893863e57e2734c89 (diff)
gnu: Add steam-devices-udev-rules.
* gnu/packages/games.scm (steam-devices-udev-rules): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/games.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2c7f892f19..09ce55f168 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -11169,3 +11169,39 @@ principle of prioritizing the guests' happiness with a well-maintained park.
Should they go unwise, a theme park plunge into chaos with vandalizing guests
and unsafe rides. Which path will you take?")
(license license:gpl2)))
+
+(define-public steam-devices-udev-rules
+ ;; Last release from 2019-04-10
+ (let ((commit "d87ef558408c5e7a1a793d738db4c9dc2cb5f8fa")
+ (revision "0"))
+ (package
+ (name "steam-devices-udev-rules")
+ (version (git-version "1.0.0.61" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ValveSoftware/steam-devices")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1yqigraz9f19018ma5n2pbx7naadh9960lia3z8ayg7vz1fjdl54"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan '(("./" "lib/udev/rules.d"
+ #:include-regexp ("rules$")))
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "60-steam-input.rules"
+ (("/bin/sh")
+ (search-input-file inputs "/bin/sh"))
+ (("udevadm")
+ (search-input-file inputs "/bin/udevadm"))))))))
+ (inputs (list eudev))
+ (home-page "https://github.com/ValveSoftware/steam-devices")
+ (synopsis "udev rules for game controllers and virtual reality devices")
+ (description
+ "This package provides a set of udev rules for game controllers and
+virtual reality devices.")
+ (license license:expat))))