summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-19 13:09:03 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-19 13:09:03 +0200
commit5f6daad3c8ebd7d39e6f9fe94be264e8de6595c4 (patch)
tree090d259d9fa49e7469323410341741e8932b7f49
parent4415a421c454817728a164db77f0437572343168 (diff)
gnu: Add r-operator-tools.
* gnu/packages/cran.scm (r-operator-tools): New variable.
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b057a299d4..df0840502d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11268,6 +11268,28 @@ package covers Models, Completions, Chat, Edits, Images, Embeddings, Audio,
Files, Fine-tunes, Moderations, and legacy Engines endpoints.")
(license license:expat)))
+(define-public r-operator-tools
+ (package
+ (name "r-operator-tools")
+ (version "1.6.3")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "operator.tools" version))
+ (sha256
+ (base32
+ "1v4dg7xhz24dnp0zxn815x1405ig64ibii6y40la1gvmzcc41dz5"))))
+ (properties `((upstream-name . "operator.tools")))
+ (build-system r-build-system)
+ (home-page "https://github.com/decisionpatterns/operator.tools")
+ (synopsis "Utilities for working with R's operators")
+ (description
+ "This package provides a collection of utilities that allow programming
+with R's operators. Routines allow classifying operators, translating to and
+from an operator and its underlying function, and inverting some
+operators (e.g. comparison operators), etc. All methods can be extended to
+custom infix operators.")
+ (license license:gpl2)))
+
(define-public r-openxlsx
(package
(name "r-openxlsx")