summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author(unmatched-parenthesis <paren@disroot.org>2022-10-21 22:11:01 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-15 02:08:41 -0500
commit5f8a2a7a69c251d788f6b8def5f7bc8524a4f09f (patch)
treeafc1b965277128fa1254fa00b73f07fe251804e7
parent02824cda55609eb4c0d991f6ebe6634ab9517178 (diff)
gnu: Add go-github-com-miolini-datacounter.
* gnu/packages/golang.scm (go-github-com-miolini-datacounter): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 61ceceea0d..b3df51ed5f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2085,6 +2085,28 @@ writers can be supplied for alternate environments.")
(home-page "https://github.com/alsm/ioprogress")
(license license:expat))))
+(define-public go-github-com-miolini-datacounter
+ (package
+ (name "go-github-com-miolini-datacounter")
+ (version "1.0.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/miolini/datacounter")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0s1hxqy6666qd524rdp1dr3778davc8gx9brg9lkcjvr5l05s9wa"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/miolini/datacounter"))
+ (home-page "https://github.com/miolini/datacounter")
+ (synopsis "Counters for Go readers and writers")
+ (description
+ "The datacounter package provides counters for Go readers and writers.")
+ (license license:expat)))
+
(define-public go-github-com-aki237-nscjar
(let ((commit "e2df936ddd6050d30dd90c7214c02b5019c42f06")
(revision "0"))