summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-21 09:24:52 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:56:30 +0200
commit5f8e51c392015a41b805a189ed41fddf6fb15eb0 (patch)
tree5e2ec6c644e05afb2438d56942c47008c0390fe8
parent9af822337c1dbe5c60a5880037568293622d145d (diff)
gnu: Add rust-trust-dns-proto-0.23.
* gnu/packages/crates-io.scm (rust-trust-dns-proto-0.23): New variable. (rust-trust-dns-proto-0.22): Inherit from rust-trust-dns-proto-0.23. Change-Id: Iacd9fd1639ba4140ddd5794c89d62245ac1b1c1a
-rw-r--r--gnu/packages/crates-io.scm73
1 files changed, 65 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ae55811bb5..6c101000c6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -84019,8 +84019,72 @@ extension for the Trust-DNS client to use tokio-openssl for TLS.")
(("rust-openssl" ,rust-openssl-0.10)
("rust-tokio" ,rust-tokio-0.1))))))
+(define-public rust-trust-dns-proto-0.23
+ (package
+ (name "rust-trust-dns-proto")
+ (version "0.23.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "trust-dns-proto" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0x6kaa9vdzq5j6yx6ik0kmp76nd4d9c1x81ii54g8my1a4k1269i"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-async-trait" ,rust-async-trait-0.1)
+ ("rust-backtrace" ,rust-backtrace-0.3)
+ ("rust-bytes" ,rust-bytes-1)
+ ("rust-cfg-if" ,rust-cfg-if-1)
+ ("rust-data-encoding" ,rust-data-encoding-2)
+ ("rust-enum-as-inner" ,rust-enum-as-inner-0.6)
+ ("rust-futures-channel" ,rust-futures-channel-0.3)
+ ("rust-futures-io" ,rust-futures-io-0.3)
+ ("rust-futures-util" ,rust-futures-util-0.3)
+ ("rust-h2" ,rust-h2-0.3)
+ ("rust-http" ,rust-http-0.2)
+ ("rust-idna" ,rust-idna-0.4)
+ ("rust-ipnet" ,rust-ipnet-2)
+ ("rust-js-sys" ,rust-js-sys-0.3)
+ ("rust-native-tls" ,rust-native-tls-0.2)
+ ("rust-once-cell" ,rust-once-cell-1)
+ ("rust-openssl" ,rust-openssl-0.10)
+ ("rust-quinn" ,rust-quinn-0.10)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-ring" ,rust-ring-0.16)
+ ("rust-rustls" ,rust-rustls-0.21)
+ ("rust-rustls-pemfile" ,rust-rustls-pemfile-1)
+ ("rust-rustls-webpki" ,rust-rustls-webpki-0.101)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-smallvec" ,rust-smallvec-1)
+ ("rust-socket2" ,rust-socket2-0.5)
+ ("rust-thiserror" ,rust-thiserror-1)
+ ("rust-tinyvec" ,rust-tinyvec-1)
+ ("rust-tokio" ,rust-tokio-1)
+ ("rust-tokio-native-tls" ,rust-tokio-native-tls-0.3)
+ ("rust-tokio-openssl" ,rust-tokio-openssl-0.6)
+ ("rust-tokio-rustls" ,rust-tokio-rustls-0.24)
+ ("rust-tracing" ,rust-tracing-0.1)
+ ("rust-url" ,rust-url-2)
+ ("rust-wasm-bindgen" ,rust-wasm-bindgen-0.2)
+ ("rust-webpki-roots" ,rust-webpki-roots-0.25))
+ #:cargo-development-inputs
+ (("rust-futures-executor" ,rust-futures-executor-0.3)
+ ("rust-openssl" ,rust-openssl-0.10)
+ ("rust-tokio" ,rust-tokio-1)
+ ("rust-tracing-subscriber" ,rust-tracing-subscriber-0.3))))
+ (native-inputs (list pkg-config))
+ (inputs (list openssl))
+ (home-page "https://trust-dns.org/")
+ (synopsis "Safe and secure DNS library")
+ (description
+ "Trust-DNS is a safe and secure DNS library. This is the foundational
+DNS protocol library for all Trust-DNS projects.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-trust-dns-proto-0.22
(package
+ (inherit rust-trust-dns-proto-0.23)
(name "rust-trust-dns-proto")
(version "0.22.0")
(source
@@ -84030,7 +84094,6 @@ extension for the Trust-DNS client to use tokio-openssl for TLS.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "09mwv7fnjrkdpf82qqvsbby5xnnpwn0kcp2cqn53br50wk8q6zsg"))))
- (build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
@@ -84069,13 +84132,7 @@ extension for the Trust-DNS client to use tokio-openssl for TLS.")
("rust-url" ,rust-url-2)
("rust-wasm-bindgen" ,rust-wasm-bindgen-0.2)
("rust-webpki" ,rust-webpki-0.22)
- ("rust-webpki-roots" ,rust-webpki-roots-0.22))))
- (home-page "http://www.trust-dns.org/index.html")
- (synopsis "Safe and secure DNS library")
- (description
- "Trust-DNS is a safe and secure DNS library. This is the foundational
-DNS protocol library for all Trust-DNS projects.")
- (license (list license:expat license:asl2.0))))
+ ("rust-webpki-roots" ,rust-webpki-roots-0.22))))))
(define-public rust-trust-dns-proto-0.20
(package