summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-13 13:04:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-13 13:17:52 +0100
commit6213e4418557dfece72c8aa12468490e68618d3b (patch)
tree2f4396732df9a258f1fc1a9aeb0d67a8b91f2d33
parent2d7627cfff63fad03f43e63234ce0d8e37f3d8d3 (diff)
gnu: Add r-noiseq.
* gnu/packages/bioconductor.scm (r-noiseq): New variable.
-rw-r--r--gnu/packages/bioconductor.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index af7259330c..15173e1659 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2020,3 +2020,30 @@ differential expression analysis, clustering, visualization, and other useful
tasks on single cell expression data. It is designed to work with RNA-Seq and
qPCR data, but could be used with other types as well.")
(license license:artistic2.0)))
+
+(define-public r-noiseq
+ (package
+ (name "r-noiseq")
+ (version "2.26.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "NOISeq" version))
+ (sha256
+ (base32
+ "1wyhhi9ydlbjlz427093mdp5ppby77n37w5c2iyxlpsdk2m2nqsn"))))
+ (properties `((upstream-name . "NOISeq")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-matrix" ,r-matrix)))
+ (home-page "https://bioconductor.org/packages/NOISeq")
+ (synopsis "Exploratory analysis and differential expression for RNA-seq data")
+ (description
+ "This package provides tools to support the analysis of RNA-seq
+expression data or other similar kind of data. It provides exploratory plots
+to evaluate saturation, count distribution, expression per chromosome, type of
+detected features, features length, etc. It also supports the analysis of
+differential expression between two experimental conditions with no parametric
+assumptions.")
+ (license license:artistic2.0)))