summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-12-30 16:06:00 -0500
committerLeo Famulari <leo@famulari.name>2018-01-10 01:22:02 -0800
commit63aade459df7ff91519c6815ba4fa02b94642715 (patch)
tree4050cb2d312067937bd7ad337acd75aeb14aca10
parentb12df4f54400a936b0e5205321886170f7381d39 (diff)
gnu: Add go-github-com-klauspost-cpuid.
* gnu/packages/syncthing.scm (go-github-com-klauspost-cpuid): New variable.
-rw-r--r--gnu/packages/syncthing.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index f544817d3d..44023617ec 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1894,3 +1894,26 @@ Authentication and Privacy Infrastructure).")
notification library in Go.")
(home-page "https://github.com/zillode/notify")
(license expat))))
+
+(define-public go-github-com-klauspost-cpuid
+ (let ((commit "eae9b3e628d72774e13bdf024e78c0802f85a5b9")
+ (revision "0"))
+ (package
+ (name "go-github-com-klauspost-cpuid")
+ (version (git-version "1.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/klauspost/cpuid.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0dgxlsxdfhfapmz1qlvc919m3kcbmfqcfpxk78zl9am5zc3zr689"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/klauspost/cpuid"))
+ (synopsis "CPU feature identification library")
+ (description "This package provides @code{cpuid}, a Go library that provides information about the CPU running the current program")
+ (home-page "https://github.com/klauspost/cpuid")
+ (license expat))))