summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-06-29 15:11:17 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-07-05 10:14:33 +0300
commit64c181d5a9528c6dca0f5168da010e8155003c52 (patch)
treee6ad501896b4a3961d7553e5b0f6dcaff783c07d
parent8b7a878de2578d9fddbec87bc93bc2ed46e5fcae (diff)
gnu: python2-pyfakefs: Remove package.
* gnu/packages/check.scm (python2-pyfakefs): Remove variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/check.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 55e4cc96ab..d4820d911d 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2849,16 +2849,13 @@ under test to interact with a fake file system instead of the real file
system. The code under test requires no modification to work with pyfakefs.")
(license license:asl2.0)))
-(define-public python2-pyfakefs
- (package-with-python2 python-pyfakefs))
-
;; This minimal variant is used to avoid a circular dependency between
;; python2-importlib-metadata, which requires pyfakefs for its tests, and
;; python2-pytest, which requires python2-importlib-metadata.
(define-public python2-pyfakefs-bootstrap
(hidden-package
(package
- (inherit python2-pyfakefs)
+ (inherit (package-with-python2 python-pyfakefs))
(name "python2-pyfakefs-bootstrap")
(native-inputs '())
(arguments