summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornafkhamdc <navid.afkhami@mdc-berlin.de>2024-03-26 12:18:33 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-03-27 15:06:54 +0100
commit64db5d6de377832a3ae73b22e1028cceff178e56 (patch)
treeec9fbdbc9301cdd66230f14c2b012ce2765be393
parenta223b1e52ba1db89b11a670915e8c9af3c3ac4af (diff)
gnu: Add python-pytest-relaxed.
* gnu/packages/check.scm (python-pytest-relaxed): New variable. Change-Id: I9c506fe6a6586c87d72775a0567fd3c45ba03568 Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/check.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index bd1f2d1b65..7fd28c3ac7 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
;;; Copyright © 2024 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1353,6 +1354,27 @@ distributed testing in both @code{load} and @code{each} modes. It also
supports coverage of subprocesses.")
(license license:expat)))
+(define-public python-pytest-relaxed
+ (package
+ (name "python-pytest-relaxed")
+ (version "2.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bitprophet/pytest-relaxed")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1lnnkadfr390i30209gpl80nymc20pmamvxjhd11gvf4d6f54n7x"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-decorator))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/bitprophet/pytest-relaxed")
+ (synopsis "Relaxed test discovery for pytest")
+ (description "This package provides relaxed test discovery for pytest.")
+ (license license:bsd-2)))
+
(define-public python-pytest-dotenv
(package
(name "python-pytest-dotenv")