summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Volf <~@wolfsden.cz>2024-06-14 19:27:00 +0200
committerChristopher Baines <mail@cbaines.net>2024-06-15 17:15:05 +0100
commit65f6bc6199ee813acadcf497f3f0b41b8b9e2839 (patch)
tree65ec66de3287ea9a6545c3e19daf4ca904e37a13
parent6a71cd419fb9d66eaa32dec59d3be1199d6c3e7d (diff)
gnu: cgit: Update to 1.2.3-4.b2c939a.
* gnu/packages/version-control.scm (cgit): Update to 1.2.3-4.b2c939a. Change-Id: Ief3b27a4fc7cfa1d4341b951957d8cd08892696b Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/version-control.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 4280d4fab8..a0f1fd18a4 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1145,8 +1145,8 @@ collaboration using typical untrusted file hosts or services.")
(license license:gpl3+)))
(define-public cgit
- (let ((commit "dbadd856ba0537110338cfe58256b152d01388c0")
- (rev "3"))
+ (let ((commit "b2c939af4bbd24882fcd28aa6b75319ca61c7c5b")
+ (rev "4"))
(package
(name "cgit")
;; Update the ‘git-source’ input as well.
@@ -1158,7 +1158,7 @@ collaboration using typical untrusted file hosts or services.")
(commit commit)))
(sha256
(base32
- "1r9mafmjgi3hknv88a1ypym6qvy2qzs1i3n6z22ddg8q4sb1wjvk"))
+ "09la0xhs9mn8k5j5z5s44pa2fv73akn4lhqpbma08f3xdhjpb3fv"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -1234,9 +1234,9 @@ collaboration using typical untrusted file hosts or services.")
(method url-fetch)
;; cgit is tightly bound to git. Use GIT_VER from the Makefile,
;; which may not match the current (package-version git).
- (uri "mirror://kernel.org/software/scm/git/git-2.45.0.tar.xz")
+ (uri "mirror://kernel.org/software/scm/git/git-2.45.2.tar.xz")
(sha256
- (base32 "0a9ljpjypszj9cxq5lk9zq8bq9v87h9fn9ph3zgyfxk4s05j1b0a"))))
+ (base32 "1nws1vjgj54sv32wxl1h3n1jkcpabqv7a605hhafsby0n5zfigsi"))))
("bash-minimal" ,bash-minimal)
("openssl" ,openssl)
("python" ,python)