summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2024-03-09 12:51:44 +0800
committer宋文武 <iyzsong@member.fsf.org>2024-03-12 18:02:07 +0800
commit671acb67abc3805a2968f4af8327c63cf2bd442c (patch)
treef314da5c70491b644a4af1810d6b5a65806d1cf7
parentff055e80e41f47a0ab5e0b89bff3595d4705d0c6 (diff)
gnu: Add xfwm4-themes.
* gnu/packages/xfce.scm (xfwm4-themes): New package. Change-Id: I01f7c7e095234c408c40cf344f6332753289d55f
-rw-r--r--gnu/packages/xfce.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index c5d61ba0d5..351ec24217 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015 Sou Bunnbu <iyzsong@gmail.com>
+;;; Copyright © 2014, 2015, 2024 宋文武 <iyzsong@envs.net>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Florian Paul Schmidt <mista.tapas@gmx.net>
@@ -949,6 +949,26 @@ menu.")
on the screen.")
(license gpl2+)))
+(define-public xfwm4-themes
+ (package
+ (name "xfwm4-themes")
+ (version "4.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://archive.xfce.org/src/art/xfwm4-themes/"
+ (version-major+minor version) "/"
+ "xfwm4-themes-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0xfmdykav4rf6gdxbd6fhmrfrvbdc1yjihz7r7lba0wp1vqda51j"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.xfce.org/")
+ (synopsis "Themes for the Xfce window manager")
+ (description "This package provides a set of additional themes for the Xfce
+window manager.")
+ (license gpl3+)))
+
(define-public xfdesktop
(package
(name "xfdesktop")