summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-05 19:29:19 +0200
committerDavid Craven <david@craven.ch>2016-08-28 14:04:53 +0200
commit6a6c9d433263fe353632e43961b709084ab1852f (patch)
treef20f1eb28738e6bd545e53a9275ac1842042120c
parent691cd90dc0db879dbd36a50868ee64fd92ac5690 (diff)
gnu: Add python-sh.
* gnu/packages/python.scm (python-sh): New variable. (python2-sh): New variable.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c461e77a3b..3e024e7431 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10076,3 +10076,30 @@ reasoning, wrappers for natural language processing libraries.")
(native-inputs
`(("python2-setuptools" ,python2-setuptools)
,@(package-native-inputs base))))))
+
+(define-public python-sh
+ (package
+ (name "python-sh")
+ (version "1.11")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "sh" version))
+ (sha256
+ (base32
+ "192r0mpv6dmkysjzhc43ddffiwb5g7c76bgr1mb1z2xz9awbj3sr"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests
+ (home-page "https://github.com/amoffat/sh")
+ (synopsis "Python subprocess interface")
+ (description "Abstracts process invocation by providing a function
+interface for programs.")
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-sh))))))
+
+(define-public python2-sh
+ (let ((base (package-with-python2 (strip-python2-variant python-sh))))
+ (package (inherit base)
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs base))))))