summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-11-22 13:35:50 -0500
committerGuillaume Le Vaillant <glv@posteo.net>2021-11-22 20:42:15 +0100
commit6ac283bad7ace27ecd66dd8718b94db4628b48e5 (patch)
tree5319a0c65e3bd23a062cc1eae744a9a2a3fdb03a
parentcb296dfa2e2938d18ae0ee347bed0cc94bc79cf8 (diff)
gnu: Add cl-cmn.
* gnu/packages/lisp-xyz.scm (cl-cmn, sbcl-cmn, ecl-cmn): New variables. Co-authored-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index a40ce00ed3..bb697c4c60 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -28,6 +28,7 @@
;;; Copyright © 2021 Cameron Chaparro <cameron@cameronchaparro.com>
;;; Copyright © 2021 Charles Jackson <charles.b.jackson@protonmail.com>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
+;;; Copyright © 2021 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19695,6 +19696,31 @@ Vernacular builds on Overlord and is inspired by Racket.")
(define-public cl-vernacular
(sbcl-package->cl-source-package sbcl-vernacular))
+(define-public sbcl-cmn
+ (package
+ (name "sbcl-cmn")
+ (version "2021.11.22")
+ (source
+ (origin
+ (method url-fetch)
+ (uri "https://ccrma.stanford.edu/software/cmn/cmn.tar.gz")
+ (file-name (string-append "cmn-" version ".tar.gz"))
+ (sha256
+ (base32 "04j1l57cdyfi2zzxqwmvmf1hl899ffgs3bl4r42ba47zsw45kq14"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://ccrma.stanford.edu/software/cmn/")
+ (synopsis "Western music notation package written in Common Lisp")
+ (description
+ "CMN provides a package of functions to hierarchically describe a musical
+score. When evaluated, the musical score is rendered to an image.")
+ (license license:expat)))
+
+(define-public cl-cmn
+ (sbcl-package->cl-source-package sbcl-cmn))
+
+(define-public ecl-cmn
+ (sbcl-package->ecl-package sbcl-cmn))
+
(define-public sbcl-cl-https-everywhere
;; No release.
;; Don't forget to update the https-everywhere input.