summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-19 13:35:23 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:59:42 +0200
commit6d45f24dee5408a54e71ff36bdfc9d9f801ec52f (patch)
tree001ad0f1ce5ab2f5a3a1163c02e792dcbf4d57bb
parent84ca518b2647aea02b6eed3fffb05a64b6527e2a (diff)
gnu: rust-swc: Prepare for cross-compilation.
* gnu/packages/rust-apps.scm (rust-swc)[arguments]: Adjust custom 'install phase to search all of the 'target' directory for the swc binary to install. Change-Id: Ib1a1ebce0ea61d14530f17a93b898e425342a1ad
-rw-r--r--gnu/packages/rust-apps.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index e1de336b99..173a1091fa 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -1361,8 +1361,9 @@ touchscreen devices.")
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (install-file "target/release/swc" bin)))))))
+ (bin (string-append out "/bin"))
+ (swc (car (find-files "target" "^swc$"))))
+ (install-file swc bin)))))))
(home-page "https://swc.rs/")
(synopsis "Typescript/javascript compiler")
(description "@code{rust-swc} is a typescript/javascript compiler. It