summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Faiz <adam.faiz@disroot.org>2023-02-20 19:53:03 +0800
committerGuillaume Le Vaillant <glv@posteo.net>2023-02-22 17:04:14 +0100
commit6d53351a6d13039eb076e584d13225e0158c5a08 (patch)
tree102b6f3a45e4df8cd40896c4b2a3bac9a5c2b0e5
parent0574aa81543c7053ce6d54a00dd0d0ae83490ad0 (diff)
gnu: gnunet: Update to 0.19.3.
* gnu/packages/gnunet.scm (gnunet): Update to 0.19.3. [source]: Add snippet. [inputs]: Replace gnurl by curl. [native-inputs]: Add python-sphinx and python-sphinx-rtd-theme. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/gnunet.scm23
1 files changed, 19 insertions, 4 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index c98ceefad7..902cd42a31 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2023 Adam Faiz <adam.faiz@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -60,6 +61,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages sphinx)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages text-editors)
#:use-module (gnu packages tls)
@@ -258,7 +260,7 @@ supports HTTP, HTTPS and GnuTLS.")
(define-public gnunet
(package
(name "gnunet")
- (version "0.16.3")
+ (version "0.19.3")
(source
(origin
(method url-fetch)
@@ -266,12 +268,19 @@ supports HTTP, HTTPS and GnuTLS.")
".tar.gz"))
(sha256
(base32
- "12n33r9nnkl5xwx8pwf571l2zvnvfllc8vm6mamrlyjk2cphaf9j"))))
+ "09bspbjl6cll8wcrl1vnb56jwp30pcrg1yyj6xy3i0fl2bzdbdw2"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ ;; This is fixed in the upstream repository but the fix
+ ;; has not been released.
+ (substitute* "src/gns/test_proxy.sh"
+ (("test_gnunet_proxy.conf") "test_gns_proxy.conf"))))))
(build-system gnu-build-system)
(inputs
(list bluez
glpk
- gnurl
+ curl
gnutls/dane
gstreamer
jansson
@@ -291,7 +300,13 @@ supports HTTP, HTTPS and GnuTLS.")
zbar
zlib))
(native-inputs
- (list curl openssl pkg-config python xxd
+ (list curl
+ openssl
+ pkg-config
+ python
+ python-sphinx
+ python-sphinx-rtd-theme
+ xxd
(@ (gnu packages base) which)))
(arguments
'(#:parallel-tests? #f ; Parallel tests aren't supported.