summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-06-25 22:28:16 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:01 +0200
commit6ea387bc614f16abacd9d3cab1a60911cd50c267 (patch)
tree52e6fd8cbeda12ca6cd4178484b625d82c910e70
parent047b7e55b315b8609e6bc2eaf18d5de36b155735 (diff)
gnu: missfits: Fetch sources from Git.
* gnu/packages/astronomy.scm (missfits)[source]: Use GIT-FETCH and GIT-FILE-NAME. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/astronomy.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 27fe4260ec..13d30caae2 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2672,11 +2672,13 @@ PixInsight. It implements XISF 1.0 specification.")
(version "2.8.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://www.astromatic.net/download/missfits/"
- "missfits-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/astromatic/missfits")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "04jrd7fsvzr14vdmwgj2f6v97gdcfyjyz6jppml3ghr9xh12jxv5"))))
+ (base32 "12ndvrr3l5j7ph2i5f3qf0wqmv5ymsyjzxnnypqajsvliw72iprh"))))
(build-system gnu-build-system)
(arguments
(list