summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-31 13:15:14 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-04 17:16:56 +0100
commit6eef249401cac3640ca3aee7501abbe27a072c67 (patch)
tree85ab3c44f759abf4097855b9ec2458072eead05a
parent569397e22fda036a49212808c5ae1693dca30be6 (diff)
gnu: Add go-code-cloudfoundry-org-bytefmt.
* gnu/packages/golang-xyz.scm (go-code-cloudfoundry-org-bytefmt): New variable. Change-Id: I1d77dd49987ad09b15149f244024831d26780e6e
-rw-r--r--gnu/packages/golang-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 1bf296bda0..415233b100 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -68,6 +68,37 @@
;;; Libraries:
;;;
+(define-public go-code-cloudfoundry-org-bytefmt
+ (package
+ (name "go-code-cloudfoundry-org-bytefmt")
+ (version "0.0.0-20240329144308-0c372429d24b")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cloudfoundry/bytefmt")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0aqzbiy3idddyj39i7ydkjhnmpcbwr99g094kqiw72m9flrvrnxj"))
+ (snippet
+ #~(begin (use-modules (guix build utils))
+ (delete-file-recursively "vendor")))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.20
+ #:import-path "code.cloudfoundry.org/bytefmt"))
+ (native-inputs
+ (list go-github-com-onsi-gomega
+ go-github-com-onsi-ginkgo-v2))
+ (home-page "https://pkg.go.dev/code.cloudfoundry.org/bytefmt")
+ (synopsis "Human readable byte formatter for Golang")
+ (description
+ "Package bytefmt contains helper methods and constants for converting to and from
+a human-readable byte format.")
+ (license license:asl2.0)))
+
(define-public go-github-com-a8m-envsubst
(package
(name "go-github-com-a8m-envsubst")