summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-03-05 22:09:28 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-17 00:04:22 +0000
commit6fda9cfd0f34498a66746a41078e29d2382f580a (patch)
tree8bf2dfaa1ad8d0a3126e374030921324732f9dec
parentcb8a8eb3752dd23b5f6e3749c0b05046d53c3646 (diff)
gnu: Add go-github-com-josharian-intern.
* gnu/packages/golang-xyz.scm (go-github-com-josharian-intern): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index d1e0666ea5..5c6e74870b 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1135,6 +1135,31 @@ and stop units of work, which may receive @code{Close} signals from many clients
struct to another.")
(license license:expat)))
+(define-public go-github-com-josharian-intern
+ (package
+ (name "go-github-com-josharian-intern")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/josharian/intern")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1za48ppvwd5vg8vv25ldmwz1biwpb3p6qhf8vazhsfdg9m07951c"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/josharian/intern"))
+ (home-page "https://github.com/josharian/intern")
+ (synopsis "String interning for Go")
+ (description
+ "This library defines functions to perform string interning in Go,
+storing only one copy of each unique string in memory. All functions may be
+called concurrently with themselves and each other.")
+ (license license:expat)))
+
(define-public go-github-com-k0kubun-pp
(package
(name "go-github-com-k0kubun-pp")