summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-10-27 19:39:50 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-29 08:32:45 +0100
commit7048d79dcd91b92111b9813382cfe0ec1be4f501 (patch)
tree46d5a3386fd7ae3c6d3f0925ab3775c17d1591ea
parent5aac9ebe8cd044aa3aa9d53fc5891a5e4dd8a16b (diff)
gnu: appstream-glib: Update style.
* gnu/packages/glib.scm (appstream-glib) [propagated-inputs]: Drop labels. [inputs, native-inputs]: Drop labels. Sort alphabetically. [arguments]: Convert to list of G-Expressions. [#:phases]<patch-tests>: Remove trailing #t. [description]: Break long line. Change-Id: I504df11ec6fc5b9d9fe70e4e32e7910f93eeb81e Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/glib.scm64
1 files changed, 33 insertions, 31 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 40de477d75..3f70808e3c 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -1305,42 +1305,44 @@ of abstraction on top of @code{sd-bus}, the C D-Bus implementation by systemd.")
"15lbrmyx94cf6p6svq02yiskh31xidq092c711pqs16mml06a9bi"))))
(build-system meson-build-system)
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("gsettings" ,gsettings-desktop-schemas) ; for ‘org.gnome.system.proxy’
- ("glib:bin" ,glib "bin") ; for glib-compile-resources
- ("pkg-config" ,pkg-config)))
+ (list gettext-minimal
+ `(,glib "bin") ;for glib-compile-resources
+ gsettings-desktop-schemas ;for ‘org.gnome.system.proxy’
+ pkg-config))
(propagated-inputs
- `(("gcab" ,gcab) ; for .pc file
- ("gdk-pixbuf" ,gdk-pixbuf) ; for .pc file
- ("libuuid" ,util-linux "lib"))) ; for .pc file
+ (list gcab ;for .pc file
+ gdk-pixbuf ;same
+ `(,util-linux "lib"))) ;libuuid, for .pc file
(inputs
- `(("glib" ,glib)
- ("gperf" ,gperf)
- ("gtk+" ,gtk+)
- ("json-glib" ,json-glib)
- ("libarchive" ,libarchive)
- ("curl" ,curl)))
+ (list curl
+ gperf
+ gtk+
+ json-glib
+ libarchive
+ glib))
(arguments
- `(#:configure-flags
- (list "-Ddep11=false"
- "-Dintrospection=false" ; avoid g-ir-scanner dependency
- "-Drpm=false"
- "-Dstemmer=false")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-tests
- (lambda _
- (substitute* "libappstream-glib/as-self-test.c"
- (("g_test_add_func.*as_test_store_local_appdata_func);") ""))
- #t))
- (add-before 'check 'set-home
- (lambda _
- ;; Some tests want write access there.
- (setenv "HOME" "/tmp"))))))
+ (list
+ #:configure-flags
+ #~(list "-Ddep11=false"
+ "-Dintrospection=false" ; avoid g-ir-scanner dependency
+ "-Drpm=false"
+ "-Dstemmer=false")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-tests
+ (lambda _
+ (substitute* "libappstream-glib/as-self-test.c"
+ (("g_test_add_func.*as_test_store_local_appdata_func);") ""))))
+ (add-before 'check 'set-home
+ (lambda _
+ ;; Some tests want write access there.
+ (setenv "HOME" "/tmp"))))))
(home-page "https://github.com/hughsie/appstream-glib")
(synopsis "Library for reading and writing AppStream metadata")
- (description "This library provides objects and helper methods to help
-reading and writing @uref{https://www.freedesktop.org/wiki/Distributions/AppStream,AppStream}
+ (description
+ "This library provides objects and helper methods to help
+reading and writing
+@uref{https://www.freedesktop.org/wiki/Distributions/AppStream,AppStream}
metadata.")
(license license:lgpl2.1+)))